Audi MMI

Rob

RMS Regular
Drives
Amarok, M5, Busa
We have a 2011 A4, the MMI randomly goes black and then comes on again. There’s no faults reported in VCDS, so took it to a local auto spark who says the offending unit is the item below which we have removed. Going to fit another off eBay, but can anyone tell me does it need coded and if so can it be easily done with VCDS?





 

Boydie

RMS Regular
Location
Co.Antrim
Drives
Audi S3 8V Revo
I don't think it does but not 100% sure - if you were changing the main radio unit then you just have to put the code in which is in the glovebox manuals usually
 

Rob

RMS Regular
Drives
Amarok, M5, Busa
I don't think it does but not 100% sure - if you were changing the main radio unit then you just have to put the code in which is in the glovebox manuals usually
Pretty sure it will have component protection on it.
Are you both meaning the same thing, i.e if we buy a second hand unit we will also need the code for it?
 

Lyons

RMS Regular
Location
Texarkana
Drives
X5 30D / MK7 R
No I believe it will need the component protection removed by either Audi or Belfast Service Centre. Circa £50 at the latter. Not sure if anywhere else that does it here but there may be.
 

Darren91

RMS Regular
Component protection for sure. You may find that it functions but the sound will be muted or other functions limited until removed.
 

Rob

RMS Regular
Drives
Amarok, M5, Busa
Component protection for sure. You may find that it functions but the sound will be muted or other functions limited until removed.
As @Lyons says, can this only be done by Belfast Audi and is it £50? Is there any way to test our own unit to prove that it is definitely faulty?
 

Darren91

RMS Regular
As @Lyons says, can this only be done by Belfast Audi and is it £50? Is there any way to test our own unit to prove that it is definitely faulty?
Main dealers are reluctant to do it and most don’t even know what it is. Belfast Service Centre or Walsh Motors can do this.

Maybe try a screen first as it’s the cheapest option?

Remember to match part numbers if you don’t have access to a parts cat as there are many many different variations.
 

Lyons

RMS Regular
Location
Texarkana
Drives
X5 30D / MK7 R
As @Lyons says, can this only be done by Belfast Audi and is it £50? Is there any way to test our own unit to prove that it is definitely faulty?
Belfast Service Centre is £50. Audi would be about £200 I imagine but doubt they’d actually do it.
 

Rob

RMS Regular
Drives
Amarok, M5, Busa
The fault can’t be the screen, because the whole MMI system reboots and takes about 2 minutes to come on again. The screen will randomly go black, music and telephone etc cut off, then after maybe 60 seconds Audi MMI will display on the screen, and then eventually it will take you back to whatever feature was previously on the screen, be it radio / nav / telephone or whatever.

Can anyone help diagnose based on that? It’s doing our head in and we need to get it sorted asap as the car is going to be for sale soon.
 

Rob

RMS Regular
Drives
Amarok, M5, Busa
The fault can’t be the screen, because the whole MMI system reboots and takes about 2 minutes to come on again. The screen will randomly go black, music and telephone etc cut off, then after maybe 60 seconds Audi MMI will display on the screen, and then eventually it will take you back to whatever feature was previously on the screen, be it radio / nav / telephone or whatever.

Can anyone help diagnose based on that? It’s doing our head in and we need to get it sorted asap as the car is going to be for sale soon.
Any ideas @Darren91 @Lyons @BBSBOY @ruairi83 @Boydie - we are going to need to have a go at replacing either the main unit in the original post, or else the module in the boot or maybe even the centre console buttons. Just can’t get a definitive answer on which it could be

DE21B73C-143A-4293-90CC-8FEBE4DC374F.jpeg
 

ruairi83

RMS Regular
Location
Derry
Drives
Sepang Blue
The fault can’t be the screen, because the whole MMI system reboots and takes about 2 minutes to come on again. The screen will randomly go black, music and telephone etc cut off, then after maybe 60 seconds Audi MMI will display on the screen, and then eventually it will take you back to whatever feature was previously on the screen, be it radio / nav / telephone or whatever.

Can anyone help diagnose based on that? It’s doing our head in and we need to get it sorted asap as the car is going to be for sale soon.
Rob, I would say go see Paul @pobmk4 at dubtech Ballymoney as he is only person who I trust and let near my car. Not much he doesn’t know about VAG cars.
 
Top