My first v8 - E39 540i

JCM

RMS Regular
Location
North Belfast
Drives
E39
Hi all,

As some of you may know, I became the new owner of @Chris tii E39. It wasn't a car I considered when looking for a replacement for my Leon MK3 but I had read it's journey all the way from Japan and became intrigued by its history.

When I saw it come up for sale, I contacted Chris to arrange a viewing and off to Bangor I went. As soon as I viewed it and sat in the passenger(got Chris to do the test drive), I could tell no expense was spared.

Long story short, Chris and myself reached an agreement and a deal was made. I thought I would start a new thread under my ownership and keep updating its journey.
I need to get the kidney grill stuck on properly and get a windshield chip repaired. Possibly take it to @big_pete when funds allow. Apart from that I have no plans of doing anything additional apart from drive it and enjoy it.

Today was the first proper drive it had to Glenariff forest park. Thoroughly enjoyed the coastal route along the way. I haven't taken any pics apart from one today.
IMG_20191026_151345.jpg
 

Chris tii

RMS Regular
Drives
e39 540i
Good to see the cars gone to a good home! Good luck with it. And hopefully get it to a few shows in the summer!
 
  • Like
Reactions: JCM

JCM

RMS Regular
Location
North Belfast
Drives
E39
I seem to have picked up the same issue as @Chris tii from his post here back in Jan 2019

On cold startup, the car has a rough idle and almost shakes the car but then goes away after driving for a while.
I also noticed last night the EML flashed for about 5secs then disappeared. Unfortunately, I've no code readers to see whether it was the same ones Chris got.

The car is booked for an oil service next week along with checking out what's causing the squealing at cold startup(have a feeling it's one of the tensioner pulleys). I will get the garage to have a look at what could be causing the rough idle.
 

Steve740

RMS Regular
Drives
740i sport
Unplug the MAF and start it up see if it cures the issue? If it does then order a new bosh maf. I’d also change the CCV valve at the back of the engine. It’s an easy DIY. You don’t have to swap the complete part
 

buster

RMS Regular
Location
bangor
Drives
MK4 AGU STAGE 2
I had an e39 335 v8 back in the day and had the exact same idle shake if the car hadn't been used for a few days. Went away though after a few mins driving
 
  • Like
Reactions: JCM

JCM

RMS Regular
Location
North Belfast
Drives
E39
It could just be a "feature" of the v8 having rough idles on cold startup but the fact that the EML flashed for 5 seconds last night is what gets me.
 

purplea4T

RMS Regular
Location
Bangor
Unplug the MAF and start it up see if it cures the issue? If it does then order a new bosh maf. I’d also change the CCV valve at the back of the engine. It’s an easy DIY. You don’t have to swap the complete part
Don't do this. The ecu will record it as a fault code and when someone plugs it in, it'll flag it upand they'll be chasing their tail. Could be any God's amount of things.
 

Steve740

RMS Regular
Drives
740i sport
Don't do this. The ecu will record it as a fault code and when someone plugs it in, it'll flag it upand they'll be chasing their tail. Could be any God's amount of things.
The fault code will disappear once he clears the codes and won’t come back, so their tail will be fine
 

Zach417

RMS Regular
Location
Derry
It could be anything, my old Citroen C2 had the same symptoms and it was a coolant temperature sensor. I wouldn’t touch anything until the faults are read.
 

JCM

RMS Regular
Location
North Belfast
Drives
E39
Got the oil service and filter done and decided to grab a code reader for myself to try and find this rough idle issue. Should come today hopefully.

Christmas also came early with this purchase.
Before
IMG_20191202_162805.jpg


After
IMG_20191202_172830.jpg


Will try and get better pics during the day but got it fitted last night.
 
Last edited:
Top