Ph1 Yaris idle not dropping

DaddyC

RMS Regular
Messages
25,671
Drives
Golf V5
Just wondering if anyone had any ideas why a Ph1 Yaris idle would just constantly sit at a steady 1100rpm from cold up to when it warms up and oil temp symbol goes out (after about 3/4 mins of sitting on tickover)? Should drop to around 7/800rpm iirc? No warning lights.

I have recently changed the maniverter and lambda sensor (as the old one was starting to rust) and everything was fine before that I think? The car has been sat up most of this year, so don't know if it just needs a good drive to clear something out? But then I'm worried about getting down the road and it overheating or something 😬

I've also changed the air filter recently so it's not clogged, checked the throttle and it seems free whether rev the car by hand on engine or via foot pedal.
 

NI_Volvo_Nut

RMS Regular
Messages
4,112
Location
Bangor
Drives
Skoda Octavia
Just wondering if anyone had any ideas why a Ph1 Yaris idle would just constantly sit at a steady 1100rpm from cold up to when it warms up and oil temp symbol goes out (after about 3/4 mins of sitting on tickover)? Should drop to around 7/800rpm iirc? No warning lights.

I have recently changed the maniverter and lambda sensor (as the old one was starting to rust) and everything was fine before that I think? The car has been sat up most of this year, so don't know if it just needs a good drive to clear something out? But then I'm worried about getting down the road and it overheating or something 😬

I've also changed the air filter recently so it's not clogged, checked the throttle and it seems free whether rev the car by hand on engine or via foot pedal.
If the battery has drained or been disconnected it is possible the ECU needs to recalibrate (learn) basic settings again. How is the idle? Is it smooth? Could also possibly be an air leak, check around the air filter as this is where you have been tinkering, could be a pipe split or has come off.
 

DaddyC

RMS Regular
OP
DaddyC
Messages
25,671
Drives
Golf V5
Idle is 100%, seems to be fine that way. Did think everything was getting a bit hotter but maybe my paranoia plus nothing in the engine bay to protect from heat lol.

I'll check round the airbox but even when i take the cover and filter off, it idles the same way. Battery I've had on a slow charger.
 

Coog

Admin
Messages
41,241
Drives
MK2 Golf
What's a maniverter? Any fault codes?

I'd try leaving the battery off for a bit and ground out the two terminals then connect it back up. I had a very similar problem on a Golf that was sat for a while with the battery off. Battery reconnect and a spin sorted it.

Also worth trying a squirt of carb cleaner round the intake post MAF to check for leaks.
 

DaddyC

RMS Regular
OP
DaddyC
Messages
25,671
Drives
Golf V5
Maniverter is a manifold with a catalytic converter built in basically. Wee tody thing for the mighty 1.0 vvti 😂

41%2B2-%2B%2B5BrL._AC_SY400_.jpg



Battery has been removed from the car pretty much this last number of months, just being left on a solar charger. Maybe I should give the battery a good charge off mains powered charger and see if it helps?

Dunno about fault codes as haven't got a reader and won't be able to get my hands on one anytime soon.
 

DaddyC

RMS Regular
OP
DaddyC
Messages
25,671
Drives
Golf V5
Unfortunately the car isn't road legal at present so I can't take it a drive. I was wondering if it needed that? I don't want to keep running it in the driveway and wrecking the cat potentially.

Thought I might have struck lucky with what Coog mentioned re battery not being fully charged and secured in place, as I just push the clamps down enough that they seek to hold as keep the battery out of the car due to being parked up. Sadly no joy after putting battery on mains charger and securing clamps fully.

Code reader would need to be next port of call really to rule anything not obvious out.
 

NI_Volvo_Nut

RMS Regular
Messages
4,112
Location
Bangor
Drives
Skoda Octavia
I wouldn't get too excited until the car is driven, if its not running rough etc, only symptom is high idle, it won't do anything other than use more fuel.

The battery doesn't do anything once the engine is running, alternator takes over and provides the voltage. Some more complicated cars with CANBUS can get upset when battery voltage is being effected by a bad battery but a Yaris isn't that complicated.
 
Top