Space Heater Repair (Sealey IR20)

RevT

RMS Regular
Messages
5,831
Anyone know someone in the NW / Mid Ulster area preferably who works on these?

Have a wee IR20 here that will start and run for about 30 seconds perfectly, then cuts out. Once it cools down for a minute or two it’ll do the exact same again.

I assumed it was some sort of thermostat thing or something but this is one of the older models with no temperature knob, just an on/off switch.
 

brendy7

RMS Regular
Messages
524
Mine did the same theres a inline fuel filter was blocked up on it if you take the panels of the back you'll see it in there would say that would be worth a try
 

RevT

RMS Regular
OP
RevT
Messages
5,831
Mine did the same theres a inline fuel filter was blocked up on it if you take the panels of the back you'll see it in there would say that would be worth a try

There is a very small looking filter down coming out of the tank on the bottom, is that the one you’ve swapped out?
 

brendy7

RMS Regular
Messages
524
More than likely it should only be one in there if you have a picture of it put it up to get a look just to make sure
 

Rob

RMS Regular
Messages
12,456
Drives
Amarok V6
The filter in the tank is a pain to take out, involves pulling the panels off her and prising the tube out of the tank, cleaned mine many times. Shoite design!

It’s a glass filter on mine so can wash it out in petrol and it does another turn. Not the easiest thing to source
 

RevT

RMS Regular
OP
RevT
Messages
5,831
I’ll maybe get a look at it later in the week and see if it’s the same setup as yours Rob. Is yours the first model IR20?
 

Rob

RMS Regular
Messages
12,456
Drives
Amarok V6
I’ll maybe get a look at it later in the week and see if it’s the same setup as yours Rob. Is yours the first model IR20?

Yeah IR20, there a few black headed screws you just need to take off around where the round red part is screwed to the base, that will allow the two parts to separate and give you access to the pipe going into the fuel tank. Fish it out of the tank and the filter should be on the end of it

I'd allow 20 mins to take apart and clean and re assemble, it's not THAT bad of a job really.
 

RevT

RMS Regular
OP
RevT
Messages
5,831
These are great wee heaters but they are so sensitive to dirty fuel.

Anyone I sell them to I gift them a handful of paper paint strainers and tell them to ensure they put the fuel through them no matter how clean they think their fuel is.

I’ve had it probably 5-6 years and it’s always been good clean fuel with no problems. The filter has never been cleaned out and I have never stripped it before for any other work. I’ll maybe get at it later in the week and see what’s going on though, would like to get it going again soon for some stuff I need to do in the garage.
 

Woodcutter

RMS Regular
Messages
31,208
I’ve had it probably 5-6 years and it’s always been good clean fuel with no problems. The filter has never been cleaned out and I have never stripped it before for any other work. I’ll maybe get at it later in the week and see what’s going on though, would like to get it going again soon for some stuff I need to do in the garage.

That’s good going getting 5-6 years trouble free use with no maintenance.

If you don’t have time to sort it, throw it in to us and we can get it sorted for you by the service/repair guy we use . 👍🏻
 

RevT

RMS Regular
OP
RevT
Messages
5,831
I thought the same, it’s been reliable, even though it’s just domestic use really. I’ll get a look at it this week some time and if I can’t sort it out I’ll give you a shout, cheers. 👍🏼
 

wings

RMS Regular
Messages
588
Drives
MK 6 GTi
My IR20 was doing the exact same thing and mines was a dirty photo cell sensor, pop the back off 4 screws and there is a black plug type thing :
1702382230480.png


I pulled that out and gave it a wipe and put its a back in and it fired up and stayed on
 

phil_20

RMS Regular
Messages
93
1702922484947.jpeg

I had to fit a new tank to mine. Old one rusted out. Added some wheels while I was at it!
Send mine to a guy near colraine to service it. Needed a new jet after the rotten fuel tank. Great guy, McNeill engineering
 

RevT

RMS Regular
OP
RevT
Messages
5,831
I forgot about Russel actually, must give him a shout if I’m stuck.
 

gcon45

RMS Regular
Messages
9,859
Location
South Derry
Drives
and rides
GS lawnmowers, Glarryford are the Sealey warranty repair agents.

Might as well get them to service it whilst it’s there.
 

gcon45

RMS Regular
Messages
9,859
Location
South Derry
Drives
and rides
PS - we brought 50 of these in when they were on promotion recently.
Think there’s ~20 left if anyone is looking for one at decent money?
£400 inc vat each.
IMG_6867.jpeg
 

zafturbo

RMS Regular
Messages
7,418
I come home from work yesterday to find my geater had emptied a full tank of fuel all over a new concrete floor .its only about 10 months old so totally baffled why its done it .to say I’m not happy is an understatement .
 

suckindiesel

RMS Regular
Messages
3,623
Location
Lisburn
Drives
A6 Allroad
My IR20 was doing the exact same thing and mines was a dirty photo cell sensor, pop the back off 4 screws and there is a black plug type thing :
View attachment 419514

I pulled that out and gave it a wipe and put its a back in and it fired up and stayed on

Had mine around 8 years, never had any bother out of it, but it was randomly cutting out, cleaned this today and it seems to have cured it thanks. Always ran it on red and filtered it. Tried kero last year and it didn't like it at all, took ages to ignite if at all, does it need adjusted in some way? Happy enough as red is hotter anyway and it's on its limit for the shed.
 

RevT

RMS Regular
OP
RevT
Messages
5,831
I haven’t even got round to looking at mine yet. I’ll see if I can sort it next week. I’m away for six weeks shortly so it’ll hopefully not be needed by the time I’m home anyway. 😂
 
Top